2017/11/17   网易云音乐官方已经发布1.1版本,但如果您的系统是18.04版本可能运行不起来,建议使用17.10版本。

我的系统是UK17.10,目前支持的内核和系统补丁应该都是最新的。

在17.10中,从官网http://music.163.com/#/download下载安装网易云音乐会出现无法运行的情况

在程序栏里运行没反应,在终端内运行 netease-cloud-music %U ,要么不提示信息要么显示如下错误

网上有网友说将命令更换为 netease-cloud-music –no-sandbox %U 执行

会提示如下错误

[1018/220422:ERROR:browser_main_loop.cc(203)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.

网易云音乐可能能打开,但打开后发现歌词无法显示。

其实,网易云音乐官方提供的是1.0.0-2版本(33.7MB),最新的版本其实1.0.1版本(50.2MB)

在安装最新版的时候发现缺少依赖:libfontconfig1(≥2.12),你会崩溃的发现就算是系统最新也才是2.11.92,就算是在网上下载了大于2.12的版本也因为破坏了系统装不上

所以自己动手重新编译了一下,安装可以从程序栏完美运行,并且不用–no-sandbox,最重要的完美支持歌词

———————————————————–分割线———————————————————–

2017.10.21更新 如果你是刚安装UK17.10正式版的新系统,首次安装网易云音乐启动后,可能会出现以下错误:
是需要VLC PLUGIN的支持
sudo apt-get install vlc-plugin-base